Video Performance Problem

New to IntelliCAD? Get started here with basic questions and answers.

Moderators: CMS Inc, avaernes

Post Reply
Rmueller818
Newbie
Posts: 1
Joined: Tue Dec 20, 2016 8:39 pm

Video Performance Problem

Post by Rmueller818 » Mon Mar 13, 2017 2:32 pm

I am running Intellicad 8.2 PE+ on a Surface Pro4 with and I7 processor. This unit is about 4 times faster than my old laptop, but is having issues with Intellicad Only. There are a large number of openings that I am working with on a fairly large plate and the video goes to a crawl. It is even worse if I try to use an external monitor. It starts out working reasonably and quickly goes to non-functional to where I have to shut the software down. I have tried this with hardware acceleration both on and off and gotten similar results. I have tried many different screen resolutions and not had success getting the correct video performance. Any suggestions on what to try. The surface is native 2736x1824
User avatar
CMS Inc
Site Admin
Posts: 97
Joined: Wed Feb 23, 2005 12:01 am
Location: Burleson, TX
Contact:

Re: Video Performance Problem

Post by CMS Inc » Fri Mar 24, 2017 1:23 pm

Can you check if your Windows 10 system has Windows KB4013429 patch installed?
User avatar
CMS Inc
Site Admin
Posts: 97
Joined: Wed Feb 23, 2005 12:01 am
Location: Burleson, TX
Contact:

Re: Video Performance Problem

Post by CMS Inc » Sat Mar 25, 2017 10:13 am

Windows KB4013429 patch is a known issue that degrades Intel HD Graphics GPUs behavior and it's affecting a significant number of software applications that use graphics hardware acceleration.

Please Revert the Graphics driver version to the previous one until Microsoft resolves the problem.

You can restore the previous driver by using the rollback option.

1 - Open Device Manager, click Start > Device Manager
2 - Expand Display Adapters
3 - Double-click on your Intel® display device
4 - Select the Driver tab
5 - Click Roll Back Driver to restore
Post Reply