Can't Open Drawing

I have ICad installed on two pc's. One is a Surface Pro 7 running Windows 11 and the other is an old HP Laptop running Windows 10.

There is one drawing that I can open on the old HP Laptop, but when I try to open it on the Surface Pro 7 ICad locks up and I must force it to close. I've un-installed and then re-installed ICad on the Surface Pro 7, but that did not help. I have other drawing files in the same folder that open without issue on both pc's.

I have no clue what to try next. Does anyone have any suggestions what might be the problem?

I think I figured it out. There was a recent maintenance update which I installed on the Surface Pro 7, but I did not install it on the old HP Laptop. Could that be the issue? Is there anyway to roll make the update on the Surface Pro 7?

I removed version 12.1.243 from the Surface Pro 7 and installed version 12.1.227 and I still locks up when trying to open that one drawing file. I must be something to do with the OS.

There was an update to WIN11 that was installed on 4/10. This is the first time trying to create a new drawing since that update.

Re: Can't Open Drawing

sln8458 wrote:
Fri Apr 19, 2024 2:33 am
Have you tried the drawing recovery option?
I can open the file on my old HP PC without issue so I don't think recovery will do anything. I did do an Audit on the drawing and it did not find any errors. Interestingly I also cannot create new drawings on the Surface Pro 7. The user account is a "Standard" account. I logged in on the Administrator account and I can then use ICad without issue. Mu guess is there is something going on with permissions.

Re: Can't Open Drawing

It is not a problem with the drawing. I can open the drawing with a different user account on the same computer or open it on a different computer.

I've attached one of several drawings ICad will not open and bombs out when I try to open it.

Keep in mind, I cannot create a new drawing from scratch either. When I try ICad locks up jsu like when trying to open the attached drawing.
Here is a sample that does not work.
(153.74 KiB) Downloaded 88 times

Re: Can't Open Drawing

The file is AC1027 (AutoCAD 2013/2014/2015/2016/2017).

I can open it on my PC with versions 10.1 thro to 12.1 with no issues.

So as you suggest it is a user permissions issue.

ATM all I can suggest is to create a new user with admin priverlidges and try using that account.

i9-12900k / 64gb-3200 - NVIDIA GeForce TRX 3060 Ti 8Gb Windows 11 Pro

Re: Can't Open Drawing

So I deleted my user account and then recreated. Re-installed software as needed. Initially Icad 12.1 worked fine, but it is back to the same drill. Some files open fine and others cause Icad 12.1 to lock up. Icad 12.0 works fine. The files I am opening are located on my local disk under my user documents folder so it is not a permissions issue. I have no clue how to correct this. It seemed to start after Windows 11 did an update a few weeks ago. Icad 12.1 works fine on my laptop running Windows 10.

Am I stuck not being able to use Icad 12.1 on my Surface Pro 7 running Windows 11? Seems that way to me right now.

Re: Can't Open Drawing

Hopefully someone sees this and can offer some suggestions on how to fix this.

If I disable Macros when 12.1 starts up everything works fine. If I enable macros, it bombs out whenever I try to open a drawing. My user folder where the CommonProjects.vbi file is stored on OneDrive. What could be wrong?

12.0 runs fine with macros enabled and the CommonProjects.vbi file stored on OneDrive.

Help please.