Error on launching the application


I just bought the app (version 11.1) and installed it on a pc that runs windows 11. When I run the app for the first time and every time after that I get an error that reads - This asert indicates that you didn't double-click on the advAddin.reg file so I'm not sure what's going on. I tried to restart pc and that didn't solve the problem. After I click OK on that message app takes very long time to start, so something is wrong, because when I tried demo version this message didn't show and app took only couple of seconds to start.
In the meantime I have uninstalled the program and reinstalled it and it still gives the same error. So any help would be great.

Re: Error on launching the application

Looks like a Microsoft Visual Basic issue.
Uninstall CMS IntelliCAD and also Microsoft Visual Basic for applications.
The reinstall CMS IntelliCAD.
Also be careful if you have the System Documents folder mapped to OneDrive, this can interfere with the installation or proper functioning of Microsoft Visual Basic.
Setup OneDrive to store Documents folder locally, but not downloading files on demand.

Re: Error on launching the application

That didn't help, the error is still present. I've also installed fresh windows 11 and the error is still present, so I'm out of ideas what to do. The program works normally, although I have not yet worked on any large files to see if the error will affect the operation of the program, the only thing that is irritating is the error that appears every time the program is started.

Re: Error on launching the application

I had this issue on multiple clean loads of W11. Installing Office 2021 resolved the issue on all machines, but have not found another resolution.

I can confirm that a window warning "This assert indicates that you didn't double-click on the advAddin.reg file" before installing office

Additionally the macro security dialog will not open, and the command line indicates something like "Visual Basic not installed for this application"

Seems a bit much to depend on MS Office, but can also confirm that the application runs fine after dismissing the error.... but it is annoying.