"sds_tblsearch"

Bonus Lisp, Vba, Tutorials etc.

Moderator: CMS Inc

Post Reply
ghosh
Contributor
Posts: 11
Joined: Mon Sep 15, 2003 11:01 pm

"sds_tblsearch"

Post by ghosh » Wed Feb 18, 2004 4:05 am

The following 'value' access problem is arrising when using "sds_tblsearch" function.

1.When we use "sds_tblsearch" for getting first entity name in the block table record. That particular entity name is not
available. But if I use your "ob_listdxf" function defined in ourbase file it is showing or printing the first entity name properly without problem.

But "sds_tblsearch" function giving result in the form of "List" which is including many list which are lengthened by two for its header and its value.

But, First entity name value is stored in the list which is having header value '-2' according to my knowledge and the working way of "ob_listdxf" function.
But when I try to access the name the particular list is not available.

I have tried by following syntax.

struct sds_resbuf* res_return;
char* block_name;
sds_name First_entity_name;

block_name = "*D0"; // "*D0" is Block name (Which defined is defined already)

res_return = sds_tblsearch("BLOCK" , block_name , 0);
struct sds_resbuf temp_list;

for(temp_list = res_return; temp_list->rbnext != NULL ; temp_list = temp_list->rbnext Image
{
//List -2
if(temp_list->restype == -2)
sds_name_set(temp_list->restype.rstring, First_entity_name);
}

As the result "First_entity_name" variable value is nil according to the value rurned "0" by the function sds_name_nil.

So, clarify or explain accessing method. Otherwise corect the syntax and send to me.
Post Reply