Osnaps don't work in model or paper space

New to IntelliCAD? Get started here with basic questions and answers.

Moderators: CMS Inc, avaernes

Post Reply
cdenk1
Contributor
Posts: 20
Joined: Mon Apr 06, 2009 3:01 pm

Osnaps don't work in model or paper space

Post by cdenk1 » Wed Nov 03, 2010 8:31 am

This is with CMS Intellicad Pro 6.6.82.0 (but have tried several other versions back to 6.2). The computer is a dual core P4, XP Pro SP3 with an ATI HD2400 video board.

I have a 3D drawing with both plan view items that have been extruded in the Z direction, and 3DPOLY lines that I am trying to dimension in the plan view. Setting the Osnaps, end, int, and cen do not snap to the object.

Opening the drawing in Progecad 9.0.28.8, I am able to easily add the dimensions to the drawing with Osnaps working good.

I could forward the drawing or attach to anyone interested.
JCAMPOS

Post by JCAMPOS » Thu Nov 04, 2010 3:34 am

cdenk1,

I suppose you had have already a similar problem in the past and managed to solved it. I did a test in the 6.6.82.0 and all OSNAP settings worked fine in model and paper space.

If you work in 3D I suggest you to work with a viewpoint different from plan UCS, so you can see to where you are really pointing the cursor.

Regards,
JCAMPOS
cdenk1
Contributor
Posts: 20
Joined: Mon Apr 06, 2009 3:01 pm

Osnaps don't work in model or paper space

Post by cdenk1 » Thu Nov 04, 2010 7:10 am

This is essentially the same problem I had previously, just coming to the next phase, the project is complete, as built changes made, now for the record want to add the dimensions and print for the file.

At first (this time around), I thought it was a corrupt drawing or something in the drawing file, exported as both ASCI and Binary DXF, and then loaded the DXF. Also did a clip board copy/paste to a new file with same results, no Osnaps.

While having the original file loaded, I also loaded a sample file from an Autocad class in 3-D I took in 1997, and the Osnaps worked good.

This made me think it was related to a setting in the drawing file, or less likely a system setting.

A second issue with the file is changing Dimscale has no effect, and I can't make the dimension the appropriate size, either model or paper space.

I had several versions of Intellicad in the computer at the same time, but currently, everything was removed with control panel and then the latest version loaded. I'll load the latest version into my Gateway nettop computer which never has had Intellicad loaded, and see what happens on a virgin install.

Thanks for the reply.
cdenk1
Contributor
Posts: 20
Joined: Mon Apr 06, 2009 3:01 pm

Osnaps don't work in model or paper space

Post by cdenk1 » Thu Nov 04, 2010 7:12 am

Forgot to mention, I do work in all views to show the cursor location as needed. Many times input coordinates by using "@", in particular to get the wanted "Z"
cdenk1
Contributor
Posts: 20
Joined: Mon Apr 06, 2009 3:01 pm

Osnaps don't work in model or paper space

Post by cdenk1 » Thu Nov 04, 2010 2:34 pm

A little more info:
1: start a new drawing
2: Draw a rectangle with the rectangle tool, 1st point anywhere, 2nd point @6,4,0
3: Set "Int" Osnap
4: Dimension the bottom line, should see 6" dimension, OK
5: Insert > 3D Entities > Extrude, 5", 0 taper.
6: Dimension top line, should see 6", "Int" doesn't snap, dimensions I get is 5.9283 (some random number near but not snapped. N.G.

Some of the entities on the main drawing are several layers deep as rectangles, extrusions, and then blocked, or Wblocked.
Post Reply