Loading Linetypes in intellicad 6.2

The VBA forum deals with IntelliCAD 2000 VBA (Visual Basic for Applications) issues.

Moderator: CMS Inc

Post Reply
ENSIGN
Valued Contributor
Posts: 26
Joined: Mon Apr 05, 2004 11:01 pm
Location: ENGLAND

Loading Linetypes in intellicad 6.2

Post by ENSIGN » Mon Sep 18, 2006 5:47 am

the routine shown below used to work on 6.1 and before but now when it is ran for the 2nd time it causes a lock-up and stops responding on the first linetypes.load line.

The error trapping is for the correctly generated error in 6.1 and before to let you know that the linetype is already loaded. removing the error trapping makes no difference.

any help on why this is happening would be appreciated.

=========================

Public Sub DefineBlocks()

On Error Resume Next

IntelliCAD.ActiveDocument.Linetypes.Load "BORDER", "ECADISO.LIN"
IntelliCAD.ActiveDocument.Linetypes.Load "CENTER", "ECADISO.LIN"
IntelliCAD.ActiveDocument.Linetypes.Load "DASHED", "ECADISO.LIN"
IntelliCAD.ActiveDocument.Linetypes.Load "DIVIDE", "ECADISO.LIN"
IntelliCAD.ActiveDocument.Linetypes.Load "DOT", "ECADISO.LIN"
IntelliCAD.ActiveDocument.Linetypes.Load "HIDDEN", "ECADISO.LIN"
IntelliCAD.ActiveDocument.Linetypes.Load "PHANTOM", "ECADISO.LIN"
IntelliCAD.ActiveDocument.Linetypes.Load "BATTING", "ECADISO.LIN"
IntelliCAD.ActiveDocument.Linetypes.Load "ZIGZAG", "ECADISO.LIN"
IntelliCAD.ActiveDocument.Linetypes.Load "TRACKS", "ECADISO.LIN"
IntelliCAD.ActiveDocument.Linetypes.Load "ACAD_ISO04W100", "ECADISO.LIN"

On Error Goto 0

End Sub

======================================
Post Reply