Enabling VBA macros

Just upgraded to iCAD 8.1 PE+ following a recent upgrade to Windows 10...

All looks good except I cannot VBARUN macros (even an empty one: Sub trial() : End Sub), via the command line or the VBA editor (which opens and operates fine in every other regard)...

- VBA macros running OK in Excel
- Clicking 'Enable macros' when iCAD starts up
- Clicking 'Enable macros' when opening a dwg file with macros
- Setting 'Security' level to medium (or low)

When I try to run a VBA macro, I always get the message:

Microsoft Visual Basic for Applications
The macros in this project are disabled. Please refer to the online help or documentation of the host application to determine how to enable macros.
OK Help

I've tried reinstalling iCAD. I've uninstalled the previous version of iCAD.

I tried to 'Repair' the installation and it could not find the 'vba71.msi' file. And, sure enough, I cannot find it anywhere, either. This sounds like where the problem lies (or maybe not?) but I haven't a clue how to fix it...

Any help would be appreciated. Thanks