Enabling VBA macros

The VBA forum deals with IntelliCAD 2000 VBA (Visual Basic for Applications) issues.

Moderator: CMS Inc

Post Reply
gruru
Newbie
Posts: 1
Joined: Wed Oct 07, 2015 1:25 am

Enabling VBA macros

Post by gruru » Thu Oct 08, 2015 11:55 pm

Just upgraded to iCAD 8.1 PE+ following a recent upgrade to Windows 10...

All looks good except I cannot VBARUN macros (even an empty one: Sub trial() : End Sub), via the command line or the VBA editor (which opens and operates fine in every other regard)...

Despite...
- VBA macros running OK in Excel
- Clicking 'Enable macros' when iCAD starts up
- Clicking 'Enable macros' when opening a dwg file with macros
- Setting 'Security' level to medium (or low)

When I try to run a VBA macro, I always get the message:

---------------------------
Microsoft Visual Basic for Applications
---------------------------
The macros in this project are disabled. Please refer to the online help or documentation of the host application to determine how to enable macros.
---------------------------
OK Help
---------------------------

I've tried reinstalling iCAD. I've uninstalled the previous version of iCAD.

I tried to 'Repair' the installation and it could not find the 'vba71.msi' file. And, sure enough, I cannot find it anywhere, either. This sounds like where the problem lies (or maybe not?) but I haven't a clue how to fix it...

Any help would be appreciated. Thanks
Post Reply