Compatibility

Topics relating to AutoLisp and SDS.

Moderators: CMS Inc, avaernes

Post Reply
markbrian
Newbie
Posts: 1
Joined: Sun Aug 08, 2004 11:01 pm

Compatibility

Post by markbrian » Sat Sep 18, 2004 12:37 am

Hello good day! is theres other way or any equivalen function in autolisp such us vl- function could run in the intellicad? Because in the intellicad basic the functin vl-load-com etc. does not run in the intellicad but the other basic lisp function runs in the intellicad basic.

Thank you...
avaernes
Valued Contributor
Posts: 129
Joined: Wed Oct 04, 2000 11:01 pm
Location: Oslo, Norway

Post by avaernes » Mon Sep 20, 2004 7:08 am

Vlisp functions are not supported in Intellicad. The only way to "enhance" standard autolisp is through doslib functions. Doslib can be downloaded from ftp://ftp2.mcneel.com/pub/doslib/doslib4.exe
The doslib4.dll file is built for Intellicad.
dooleybob41
Newbie
Posts: 7
Joined: Fri Jun 29, 2018 4:07 pm

Re: Compatibility

Post by dooleybob41 » Wed Jul 18, 2018 11:09 am

This is an old post, but I can't find anything newer on the subject of DOSLIB.

I've used DOSLIB for quite a long time with AutoCAD, and want to use it with IntelliCAD. My problem is that the link to doslib4 at a McNeel ftp site is no longer a valid link.

I downloaded doslib903.brx.zip from McNeel's Website. It includes a doslib history that indicates that doslib4 was for visios intellicad 98. The newest version, of doslib, 9.0.1, is for AutoCAD 2007 - 2018, and BricsCAD Pro V9 - V17.

I have IntelliCAD 8.4 PE+, and am going to try the doslib 9.0.1 version for BricsCAD. Hope it works

dooleybob41
Post Reply