CMDECHO Unexpected Results

Topics relating to AutoLisp and SDS.

Moderators: CMS Inc, avaernes

Post Reply
Jim Frame
Posts: 3
Joined: Tue Jul 09, 2013 9:42 am

CMDECHO Unexpected Results

Post by Jim Frame » Wed Jul 10, 2013 10:25 am

When I set CMDECHO to 0 in an AutoLISP routine that uses the COPY command, I get a notification (e.g. "Current settings: Copy mode = Single") sent to the display. When the routine is dealing with multiple (sometimes thousands) of copy operations, this is pretty annoying. The behavior is not present when executing within AutoCAD.

Is there any way to suppress the "Current settings" notification when executing COPY via AutoLISP within IntelliCAD?

Posts: 21
Joined: Fri Mar 22, 2019 1:57 am

Re: CMDECHO Unexpected Results

Post by UberEber » Sat May 04, 2019 7:01 am

;tried xplode
;explode etc

(command "-xplode" "last" "" "LA" Layer-Name ) ;Xplode the entity onto the layer revealing xData
(princ "") ;Sad but it does not do this quietly...

and all combinations
it just will not shut up ...

Apparently still not fixed.
Post Reply