How does one go about adding new shape file fonts to the latest ICAD 2001 version (I am using the latest CMS ICAD 2001)??

In previous versions the fonts could be copied to a font directory with the correct path assigned in tools/options menu. However, this does not work, the copied fonts do not show up in the style popup box. If the "load" command is used the fonts can be picked but when open is chosen the dialog box closes but the fonts are not available in the style change box.

Am I missing something???

Please help!!!!

Thank you,


Have you tried putting a copy of the font into your Windows > Fonts directory? I realize that you should not have to do this but it may be a quick workaround until the situation can be looked into and remedied. I know it works for TTF's.



I tried to copy the shx fonts to the windows font folder, however, win98se would not allow me to undertake this action saying that the fonts are not recognized. Any way around this or other thoughts????

Thank you again,


[This message has been edited by Scott (edited 08-27-2001).]


I have some .shx fonts working on my version of 2001. Could you please mail me your font file that you are trying to get to work maybe I can help you figure out what the problem is.


My mistake, Win98 will not let you copy .shx to the fonts directory, it has to be done through Dos. Still would not read it though. I tried a variety of ways with no luck and believe you may have found a new glitch unless tooldesigner can come up with a workable solution until this can be remedied.


I have a drawing with my .shx font in it that I copied over to the new version.

Only problem is, I cannot use the IntelliCAD explorer to add a new font name even though the my .shx font is in the drawing.

From the Text Style Dialog box I selected a new style name and my .shx font copied a the default.

Try another drawing that has the fonts you want to use in it as your prototype.

John Finlay
Don't want to post a question - email me direct on

Thank you Melodi, Tooldesigner, and John I will try the things you suggested.

Just curious----Where does ICAD store the font information?? Is it in the registry or other place??? Is there a way to manually add fonts??

Thank you again,


[This message has been edited by Scott (edited 08-28-2001).]

I have add .shx fonts to my drawings. I add fonts that came from differnt Drafting programs. There was one file that wouldn't load for some reason. I added the fonts to CMS> Intellicad ***> fonts. Then I made sure that in the options menu point to that directory. I went to browse and picked that directory to enusre that it was reading from that directory. If you wouldn't mind sending me your .SHX file. So I can try that one too or tell me that name I might have it already. I hope this helps.

You can send that file to


You should be able to import .shx fonts into
Icad directory. Doing this you don't need to
set any paths. Having done this:-

Open up Icad Explorer by and create new Style.
Double click on font column and scroll down to your .shx font. Then adjust height,width etc by double clicking on appropriate column.
Double click on new style to make it current

Exit Explorer and choose Dtext (single line text).
This works O.K.

If you want to use Mtext don't use Icads MText Editor as current Icad version has bug which won't allow you to use text with height greater than about about 65 (I work
in mm)

To use Mtext you must alter the MTEXTED system variable to
use another text editor.

eg. MTEXTED.....return

brings up Notepad as your Mtext Editor.

(To get back to Icads standard Mtext editor


Multiline .shx text appears correctly when created in Notepad.

You can even call up Word as your Mtext Editor.
However you must use an abbreviated dos path as Word installs into Program Files\Microsoft Office directorys
containing spaces. Using space bar throws you out of command.

eg. MTEXTED......return

I believe the problem seem to be dependant on particular fonts as some .shx seem to incorporate with no problem (tooldesigner's and David's) while others (Scott's, John's and mine) cannot be seen. I have a font that is Thai55.shx that will not show up in a new drawing no matter what I have tried, including adding the path or copying the font into the IntelliCAD font directory. What’s more, if I load a previous release’s drawing that used this font it will show up in the Explorer under whatever style it was assigned to … but, if I happen to switch that font to any other than try to re-assign the Thai55 font it is no longer showing. I have also tried to wblock out text that this font was assigned to and when inserted into another drawing it was converted to another font. John’s way of using a current drawing that has the font loaded is a workable solution. I had to access this font using the “Style” dialog box, as he states, where it shows up as the default font.

I would be happy to send this font to anyone else that would like to try it.


Thank you all for your replies,

I concur with John and Melodie. I have a number of fonts from previous AutoCAD versions, *.shx, that I typically copy into the Intellicad font directory, however, they are not recognized when trying to find them in the style change dialog. As John states they are available when opening a drawing that uses them.

NOTE: The "standard" ICAD *.shx fonts work fine, the fonts that are present in the fonts folder of ICAD when it is loaded.

By the way, one of the fonts is fontpre-.shx, I don't know if anybody else is using this font.

Thank you again for your responses and help.


[This message has been edited by Scott (edited 08-30-2001).]

Scott I really would like it if you could mail me some of the fonts you are having trouble with. I would like to help you out but I don't have any of the fonts you are having problems with. Thanks.


I will email you some fonts tonight. Thank you for your reply.

I have been having other problems related to fonts that are not listed in style dialog box. See posting "Fonts crashing Icad" for details.

Thank you



I should have mentioned this in my original posting.

John is quite right in saying you can get get .shx fonts to work by using a template drawing containing the font created in Acad.

However, for those without access to Acad there is a workaround hidden in Icad.

Set up your .shx style as detailed in my original posting and set it current. Then using an alternative text editor eg Notepad write a block of text in Dtext. This can be as short as one letter. Dtext will correctly display this text style as you have set it up in Icad explorer in terms of height, width etc.

With this style now in the drawing (AS AN ENTITY) Mtext will, using an alternative text editor, now display the style correctly.

PS Dump these .shx Fonts into the main Icad directory...NOT the Icad Fonts directory.

[This message has been edited by David Neale (edited 09-01-2001).]

Also noticed another problem using the .shx font style created above in a dimension. If you try to alter the text height from within the dimension setup dialogue style reverts to txt. Probably related to this thing of the .shx font at a particular height or width having to be present in the drawing AS AN ENTITY.

[This message has been edited by David Neale (edited 09-02-2001).]